【重要連絡】24H2 環境では、Windows PE ブートエージェントを作成する機能が動作しない
(2025年 1月 9日 発行)
(2025年 9月2日 更新)
事象
システムリカバリサーバ機能を「Windows 11 2024 Update (バージョン24H2)」環境にインストールした場合、「Windows PE ブートエージェント」を作成する機能が動作しません。
対象製品
- Systemwalker Desktop Restore Professional V16
- Systemwalker Desktop Restore Standard V16
- Systemwalker Desktop Restore Cloning Grade V16
- 瞬快 tokujyo(特上) Ver.13
- 瞬快 jyo(上) Ver.13
- future瞬快 Advanced Grade(AG) V4L60以降
- future瞬快 Cloning Grade(CG) V4L60以降
原因
「Windows 11 2024 Update (バージョン24H2)」もしくは Windows ADK に問題があります。
対処
2025年6月9日より、次のADKとアドオンを使用できるようにした対応プログラムの提供を開始しました。
Windows ADK 10.1.26100.2454 (2024年12月)
https://go.microsoft.com/fwlink/?linkid=2289980
Windows ADK 10.1.26100.2454 (2024年12月) 用の Windows PE アドオン
https://go.microsoft.com/fwlink/?linkid=2289981
これにより、システムリカバリ機能の使用に際し、「Windows 11 2024 Update (バージョン24H2)」環境でも「Windows PE 10.0 22H2」の場合と同等の Windows PE ブートエージェント の作成が可能となります。
これらのADKとアドオンを使用する際には、事前にアップデートキャッチャー機能により提供されている次の何れかのアップデートをシステムリカバリサーバ機能に適用しておく必要があります。
- 2025年6月9日提供開始の「システムリカバリ用 Windows PE ブートエージェント」
- 2025年8月14日提供開始の「システムリカバリ用 Windows PE ブートエージェント(作業ディレクトリ変更版)」
アップデートを適用可能な製品は次のとおりです。
- Systemwalker Desktop Restore Professional V16.0.1 A
- Systemwalker Desktop Restore Cloning Grade V16.0.1 A
- Systemwalker Desktop Restore Standard V16.0.1 A
- 瞬快 tokujyo(特上)Ver.13e
- 瞬快 jyo(上)Ver.13e
- future瞬快 Advanced Grade(AG)V4L90初版
- future瞬快 Cloning Grade(CG)V4L64
なお、Cドライブ以外にシステムリカバリサーバ機能をインストールしている環境では、2025年6月9日提供開始の「システムリカバリ用 Windows PE ブートエージェント」を適用すると、ブートエージェント作成時に「作業ディレクトリの作成に失敗しました。」のエラーが発生し、ブートエージェントを作成することができません。
この状態となった場合には2025年8月14日提供開始の「システムリカバリ用 Windows PE ブートエージェント(作業ディレクトリ変更版)」を追加適用してください。
補足1
上記当社製品のマニュアルには次のとおり Windows ADK ダウンロード用URLを記載していますが、2025年5月29日の再発行により新しいバージョンの Windows ADK がダウンロードされるようになっています。
(1)Windows ADK for Windows 11 Version 22H2 (Windows PE 10.0.22H2)
ADK for Windows 11 バージョン 22H2 (再発行によるファイルバージョンの変更:10.1.22621.1 → 10.1.22621.5337)
https://go.microsoft.com/fwlink/?linkid=2196127
Windows PE アドオン (ADK 用) バージョン 22H2 (再発行によるファイルバージョンの変更:10.1.22621.1 → 10.1.22621.5337)
https://go.microsoft.com/fwlink/?linkid=2196224
(2)Windows ADK for Windows 10 Version 2004 (Windows PE 10.0.2004)
ADK for Windows 10 バージョン 2004 (再発行によるファイルバージョンの変更:10.1.19041.1 → 10.1.19041.5856)
https://go.microsoft.com/fwlink/?linkid=2120254
Windows PE アドオン (ADK 用) バージョン 2004 (再発行によるファイルバージョンの変更:10.1.19041.1 → 10.1.19041.5856)
https://go.microsoft.com/fwlink/?linkid=2120253
(3)Windows ADK for Windows 10 Version 1809 (Windows PE 10.0.1809)
ADK for Windows 10 バージョン 1809 (再発行によるファイルバージョンの変更:10.1.17763.1 → 10.1.17763.7320)
https://go.microsoft.com/fwlink/?linkid=2026036
Windows PE アドオン (ADK 用) バージョン 1809 (再発行によるファイルバージョンの変更:10.1.17763.1 → 10.1.17763.7320)
https://go.microsoft.com/fwlink/?linkid=2022233
これらへの対応状況は次のとおりです。
(1)については再発行版を入手したとしても上記対処を実施する必要があります。
(2)(3)については再発行版の Windows ADK にて本問題が改善されています。
補足2
(1)への対応については次の製品にて吸収され、以降の製品では標準機能にて対応しています。
- Systemwalker Desktop Restore Professional V16.0.1 B
- Systemwalker Desktop Restore Cloning Grade V16.0.1 B
- Systemwalker Desktop Restore Standard V16.0.1 B
- 瞬快 tokujyo(特上)Ver.13f
- 瞬快 jyo(上)Ver.13f