GTM-MML4VXJ
Skip to main content

English

Japan

  1. ホーム >
  2. サポート >
  3. FAQ(よくある質問)

FAQ(よくある質問)

ER/Studio

[表示]


[比較とマージ]


[操作]


[全般]


[モデリング]


[フォワード エンジニアリング]


[データベース生成/リバース エンジニアリング]


[データベース接続]


[データ ディクショナリ]


[オートメーション インターフェース/マクロ]


[インポート/エクスポート]


[インストール/起動/ライセンス]


[ER/Worksheet]


[ELC]

表示

[161] リレーションシップの線の描画モードを直線以外に変更できますか?

直線、矩形線、および多角線で描画できます。

■直線または矩形線で描画する場合
以下のいずれかの方法で行なえます。

  • 新しく作成するデータ モデルのリレーションシップを変更する場合
    1. [オプション] ダイアログ ボックス ([ツール] メニューの [オプション] をクリック) の [表示] タブを表示します。
    2. [モデル表示] グループの [線描画モード] で [矩形線] または [直線] を選択します。
  • 現在のデータ モデル上で、選択したリレーションシップを変更する場合
    1. 変更するリレーションシップを選択した後、[フォーマット] メニューの [リレーションシップのレイアウト] で [矩形線] または [直線] を選択します。
    2. 変更するリレーションシップを右クリックして、ショートカット メニューの [リレーションシップのレイアウト] をクリックし、[矩形線] または [直線] を選択します。
  • 現在のデータ モデル上で、新しく作成するリレーションシップを変更する場合
    1. [ダイアグラムとオブジェクトの表示オプション] ダイアログ ボックス ([表示] の [ダイアグラムとオブジェクトの表示オプション] をクリック) で [リレーションシップ] タブを表示します。
    2. [リレーションシップの表示設定] グループの [リレーションシップ描画モード] で [矩形線] または [直線] を選択します。

■多角線で描画する場合
多角線で描画するには、リレーションシップが “直線” に設定されている必要があります。

  1. 多角線で描画したいリレーションシップを選択します。
  2. 線上の折り曲げたい点にマウス ポインタを移動します。
  3. 任意の位置までドラッグし、線を折り曲げます。

161


[166] 特定のエンティティ (テーブル) に色を設定することはできますか?

以下の方法にて、設定することができます。

  1. 色を設定したいエンティティ (テーブル) を右クリックします。
  2. [エンティティ (テーブル) の色とフォントの設定] の [エンティティの背景 / 外枠の色 (選択したテーブルの色) ] を選択します。
  3. [エンティティ (テーブル) の色] ダイアログ ボックスで、設定を変更します。

※色の変更をサブモデルにも適用したい場合は、[すべてのサブモデルに適用] チェック ボックスをオンにします。


[401] モデルの表記法を変更できますか?

これから作成するモデルのデフォルト表記法を変更するには、次の手順を実施します。

  1. [ツール | オプション] メニューをクリックします。
  2. [論理] タブの [表記法] グループで任意の表記法を選択します。
  3. [物理] タブの [表記法] グループで任意の表記法を選択します。
  4. [OK] をクリックします。

現在開いているモデルの表記法を変更するには、次の手順を実施します。

  1. [モデル | モデル オプション] メニューをクリックします。
  2. [全般オプション] タブの [表記法] グループで任意の表記法を選択します。
  3. [OK] をクリックします。

< 対象バージョン: 9.x、10.0、16.0 >


比較とマージ

[147] 論理モデルの変更点を物理モデルに反映できますか?

比較とマージ機能を使用して反映することができます。

業務ルールの変更等で論理モデルに変更があった場合、比較とマージ機能を使用して、論理モデルの変更内容を物理モデルに反映させることができます。


[157] 物理モデルの変更点をデータベースに反映できますか? データベースの変更点をモデルに反映できますか?

比較とマージ機能で、物理モデルとデータベースを比較して、異なる箇所 (変更点) を検出できます。
検出された内容は、データベースまたは物理モデルに反映 (マージ) できます。

データベースに対して比較するには、ネイティブ接続でデータベースに接続している必要があります。ODBC 接続では、データベースに対して比較することができません。


[388] 比較とマージ機能で、SQL ファイル/データベースにマージするための ALTER 文が出力できません

この問題は、バージョン 9.6 で解決されています。この問題は、バージョン 9.5 固有のバグです。

対象データベースが Oracle で、比較とマージ機能のオプションで [SQL ファイルと比較]、または [データベースと比較] を選択して、[ターゲットへマージ] を選択すると発生します。

< 対象バージョン: 9.5 >


[390] SQLファイルとの比較とマージについて

ER/Studio Data Architect 9.6、9.7、10.0、16.0 では、比較とマージする時に次のデータベースに対応する SQL ファイルを選択するした場合、エラーが表示されることがあります。

  • Microsoft SQL Server
  • Sybase ASE
  • Syabse ASA
  • Teradata

本件は、問題として、開発元へ修正を要求しています。

< 対象バージョン: 9.6、9.7、10.0、16.0 >


操作

[141] エラー "パスが見つかりません" が表示され、モデルを開けませ

本現象が発生した場合は、あらかじめ ER/Studio Data Architect を起動し、[ファイル] メニューの [開く] をクリックし、該当のモデル ファイル (.dm1) ファイルを開いてください。


[165] ER 図上で、エンティティ/テーブルや属性/カラム名称を編集できますか?

モデル ウィンドウ (ER 図) 上でエンティティ (テーブル) 名を変更したい場合は、 < Shift > キーを押しながら、エンティティ (テーブル) 名をクリックすると、名前が編集可能になります。

属性 (テーブル) 名の場合も、エンティティ (テーブル) 名同様に操作することで、名前を編集することができます。


[167] 複数の属性 (カラム) を同時に選択することはできますか?

[ダイアグラム] ツールバーの [属性選択ツール](指先のアイコン) を選択し、 < Ctrl > キーを押しながら属性を選択することで、複数の属性を選択できます。


[172] コピー&ペーストして、エンティティを作成しても問題ありませんか?

エンティティにリレーションシップを設定していない場合には、コピー&ペーストにて、新規のエンティティを作成することができます。

リレーションシップを設定している場合には、一旦、リレーションシップの設定を削除した後に、コピー&ペーストしてください。リレーションシップを設定している場合、外部キーの情報などの継承に問題が発生する可能性があります。


全般

[123] 何故、論理ダイアグラムと物理ダイアグラムに分かれているのですか?

論理ダイアグラムは、業務要件に着眼して、分析やデータ モデリングを行なうためのものです。論理設計では、設計に関する重要な分析や評価を行なう必要がありますので、論理ダイアグラムを使用します。

物理設計では、データベース プラットフォームに応じて、物理ダイアグラムを使用します。


[124] オブジェクトは論理設計から物理設計にどのように変換されますか?

ER/Studio Data Architect では、[物理モデルの生成]ウィザードを使って、論理モデルに基づいてリレーショナルまたは多次元の物理モデルを生成できます。[物理モデルの生成]ウィザードでは、生成する物理モデルのデータベース プラットフォームを選択でき、対象データベース プラットフォームの基本的な命名ルールや構文ルールに準拠したり、参照整合性を生成(インデックスまたはテーブル制約を使用した論理キーの実装など)することができます。 また、論理モデルと物理モデルのデータ型のマッピングや、名前付けテンプレートによる物理名と論理名の置換をカスタマイズ可能です。

なお、以下のタイプのリレーションシップが設定された論理モデルから物理モデルの生成を行なうと、物理モデルでは以下のように変換されます。

  • サブタイプ クラスタ リレーションシップ:物理モデルでは依存型リレーションシップに変換されます。
  • 多対多のリレーションシップ:関連テーブルを作成するか、リレーションシップを持たないテーブルを作成するか選択することで、多対多のリレーションシップを解決することができます。

[126] 論理モデルと物理モデルをいくつ作成できますか?

ER/Studio Data Architect は、1つのモデル上で1つの論理ダイアグラムと複数の物理ダイアグラムを作成することができます。


[184] 最大で何個のエンティティやリレーションシップを作成できますか?

エンティティ、属性、リレーションシップなどに数の制限はありません。 また、現在表示しているモデルに作成されたエンティティ/テーブル、属性/カラム、リレーションシップ/外部キー、ビューの総数は、ステータス バーに表示されます。


[185] 最大何ページの用紙に印刷できますか?

モデル縮尺率 100% の状態で、A4 縦の用紙に縦 43 枚、横 30 枚、合計 1,290 ページのページ領域を持っており、そのすべてを印刷することができます。


[387] .dm1 ファイルを開こうとすると、エラー "プログラムにコマンドを送信しているときに、エラーが発生しました" が表示されます

モデル ファイル (.dm1) をダブルクリックで開こうとすると、エラー メッセージ "プログラムにコマンドを送信しているときに、エラーが発生しました" が表示されることがあります。

このメッセージが表示された場合、ER/Studio Data Architect の [ファイル | 開く] メニューで、.dm1 ファイルを開いてください。


[391] RTF レポートで、目次のページ数がすべて "8" になります

RTF レポートにおいて、目次ページ数がすべて "8" と表示されることがあります。

これは、Microsoft Word のセキュリティ設定において、マクロが無効に設定されていることで発生します。

Word 2007 の場合、次の手順でマクロを有効にすることができます。

  1. Microsoft Word の Office ボタンをクリックして、[Word のオプション] をクリックして、[Word のオプション] ダイアログ ボックスを開きます。
  2. [Word のオプション] ダイアログ ボックスの [セキュリティ センター] をクリックして、[セキュリティ センターの設定] をクリックして、[セキュリティ センター] ダイアログ ボックスを開きます。
  3. [セキュリティ センター] ダイアログ ボックスの [マクロ] をクリックし、[マクロの設定] で [すべてのマクロを有効にする (推奨しません。危険なコードが実行される可能性があります)] をクリックします。
  4. [OK] をクリックして、[セキュリティ センター] ダイアログ ボックスを閉じます。
  5. [OK] をクリックして、[Word のオプション] ダイアログ ボックスを閉じます。

[392] ER/Studio DA 9.7 のヘルプが古いバージョンのものです

この問題は、バージョン 10.0 で解決されています。この問題は、バージョン 9.7 固有のバグです。

ER/Studio Data Architect 9.7 に組み込まれているヘルプ ファイル (ERStudioDA.chm) が古いバージョンのものであるため、発生しています。

< 対象バージョン: 9.7 >


モデリング

[121] 依存型リレーションシップを使うと、どのように主キーを子エンティティへ移行できますか?

依存型リレーションシップを作成すると、親から子へ外部キーをキー属性として移行します。 外部キーは、子の仕切線の上に移行され、主キーの一部であることを示す赤色で表示されます。したがって、依存型リレーションシップにおける外部キーの値は、親の主キーの値を参照し、子の主キーに含まれます。

121


[122] 非依存型リレーションシップを使うと、どのように主キーを子エンティティへ移行できますか?

非依存型リレーションシップを作成すると、親から子へ外部キーを非キー属性として移行します。
外部キーは、子の仕切線の下に移行され、主キーの一部でないことを示す青色で表示されます。したがって、外部キーの値は、主キーの値を参照しますが、子の主キーには含まれません。

122


[128] 論理モデルでは無効なビューが、物理モデルでは有効となるのはどうしてですか?また、結合の有効/無効が、論理モデル/物理モデルで異なるのはどうしてですか?

論理モデルでは、標準の ANSI92SQL に基づいて、検証を行います。物理モデルではそれぞれのデータベースの SQL に従って検証を行います。そのため、論理モデルでは、無効と判断された場合も、物理モデルでは、View を定義する SQL が、それぞれのデータベースの SQL に従っている場合には、有効になります。

結合についても、同様に、論理モデルと物理モデルとで基準とする SQL が異なるために、有効/無効に違いが発生します。


[130] エンティティ名を変更しても、テーブル名が自動的に変更されません

エンティティ名とテーブル名をシンクロ (同化) させるには、[名前の処理] オプションを設定します。

  1. [ツール] メニューの [オプション] を選択し、[オプション] ダイアログ ボックスを開きます。
  2. [名前の処理] タブを表示します。
  3. [論理名設定オプション] グループで対応するオプションを設定します。

関連するオプションの詳細は以下のとおりです。([論理名設定オプション] の [エンティティ名とテーブル名])

  • 完全シンクロ: エンティティ名を変更するとテーブル名も自動的にシンクロして変更されます。
  • 部分シンクロ: テーブル名を明示的に入力しない限り、エンティティ名を変更するとテーブル名も自動的にシンクロして変更されます。(デフォルト)
  • シンクロしない: エンティティ名とテーブル名はシンクロしません。テーブル名を手動で設定する必要があります。

[131] サブタイプ クラスタを作成したいのですが…

サブタイプ クラスタは、論理モデルでのみ作成できます。

サブタイプ クラスタが含まれた論理モデルから物理モデルを生成すると、サブタイプ クラスタは以下のように変換されます。

  • スーパー タイプ:親テーブル
  • サブタイプ:子テーブル
  • リレーションシップ:依存型リレーションシップ or 非依存型リレーションシップ

[133] 再起リレーションシップは、どのようにして作成しますか?

以下の方法にて、作成します。

  1. [モデリング] ツールバーの [非依存型リレーションシップ] をクリックします。
  2. 再起リレーションシップを作成したいエンティティ (テーブル) を2回クリックします。(リレーションシップ作成時の親を選択し、子を選択するのと同じ要領です。)
  3. [再起リレーションシップ] ダイアログ ボックスにて、属性 (カラム) のロール名を入力します。

[156] 物理モデルからデータベースの物理スキーマを構築できますか?

[データベース生成]機能を使用し、物理モデルをデータベースへ簡単にフォワード エンジニアリングすることができます。


[163] 主キー属性に設定された[定義]は、その子エンティティの外部キーに継承されますか?

リレーションシップ作成時には自動的に継承されますが、リレーションシップ作成後に親エンティティの主キー属性の[定義]を変更しても、子エンティティの外部キーには反映されません。

リレーションシップ作成後に親エンティティの主キー属性の[定義]を変更した場合は、リレーションシップを作成しなおすことで、親エンティティの変更内容を子エンティティに反映させることができます。


[171] Oracle のパーティションで対応しているタイプは何ですか?

Oracle のパーティションで対応しているタイプは、次の 4 種類です。

  • RANGE
  • HASH
  • COMPOSITE(Hash、List)
  • LIST

[173] 外部キーの一意化機能 (重複属性エディタ) とは何ですか?

リレーションシップの作成において、親エンティティと子エンティティで同じ名前の属性が存在する場合に、[重複属性エディタ] が表示され、同名の属性に対して移行設定を行なうことができます。

[重複属性エディタ] にて [既存属性と移行属性を一意化する] を選択すると、移行された外部キー属性と既存の属性が同じものとして扱われ、置き換えとは異なり、リレーションシップを削除した場合に既存の属性が削除されずに保持されます。この機能を "外部キーの一意化機能" といいます。

ただし外部キーの一意化機能を使用して、属性を一つに (一意化) したとしても、物理モデルを生成した際には、別々のカラムとして生成される場合があります。 これを避けるためには、既存属性と移行属性のカラム名を同一にした後、[既存属性と移行属性を一意化する] を実行してください。

173


[180] リバースエンジニアリングすると、論理モデルと物理モデルのオブジェクト名が同じになりますが、複数の論理モデルのオブジェクト名をまとめて変更する方法はありますか?

複数の論理モデルのオブジェクト名をまとめて変更するには、次のいずれかの方法を実施します。

[名前付け標準ユーティリティ] で変更する
[名前付け標準ユーティリティ] にて、物理名と論理名の変換辞書を基に、物理名から論理名を生成します。

オブジェクト名称変更ユーティリティで変更する
[ツール]メニュー- > [オブジェクト名称変更ユーティリティ...]

Naming Utility で変更する
弊社 提供の Naming Utility を使用します。
Naming Utility は、弊社より ER/Studio Data Architect のメンテナンス契約を締結中のお客様へ提供しているフリー ツールです。
https://www.fujitsu.com/jp/group/fetec/inquiry/dl-download.html

ER/Worksheet で変更する
弊社 提供の ER/Worksheet (Excel アドイン) を使用します。
ER/Worksheet は、弊社と ER/Studio Data Architect のメンテナンス契約を締結中のお客様へ提供しているフリーウェアです。
https://www.fujitsu.com/jp/group/fetec/inquiry/dl-download.html


[404] Oracle 物理モデルのビュー オブジェクトで構文エラーになりません

ER/Studio Data Architect 10.0 および 16.0 の Oracle プラットフォームにおいて、DDL 検証 で一部のエラーがエラー表示されずに、正しい DDL と認識されることがあります。

GROUP BY 項目の不足または、グループ関数の未設定を検証 (検出) できません。

< 対象バージョン: 10.0、16.0 >


フォワード エンジニアリング

[159] 物理モデルで参照整合性を保持するためのトリガーを生成できますか?

物理モデルでトリガーの内容を選択すると、トリガー コードを自動生成します。


データベース生成/リバース エンジニアリング

[174] 既存のデータベースからリバース エンジニアリングできますか?

データモデルの作成時に [既存のデータベースからリバース エンジニアリング] を選択することで可能です。

ER/Studio Data Architect (DA) バージョンによって、リバース エンジニアリング可能なデータベースやデータベース バージョンが異なります。各 ER/Studio DA バージョンの要件を確認してください。

最新版のER/Studio DA のシステム要件については、次の URL を参照してください。
http://www.fujitsu.com/jp/group/fetec/solution/erstudio/


[175] SQL スクリプトからリバース エンジニアリングできますか?

可能です。バージョンによってリバース エンジニアリング可能なデータベースやデータベース バージョンが異なります。

ER/Studio Data Architect 16.0 では、次のデータベースの SQL スクリプトからのリバース エンジニアリングに対応しています。

  • IBM DB2 AS/400 4.x、5.x
  • IBM DB2 Common Server
  • IBM DB2 UDB 5.x、6.x、7.x、8.x、9.x、10.x
  • IBM DB2 UDB for OS/390 5.x、6.x、7.x、8.x、9.x、10.x
  • Microsoft SQL Server 6.x、7.x、2000、2005、2008、2012、2014
  • Microsoft Azure SQL Database
  • Oracle 7.x、8.x、9i、10g、11g、12c
  • Sybase ASA 6.0、7.0、8.0、9.0、10.0
  • Sybase Adaptive Server IQ 12.5、15、16
  • Sybase ASE 11.0、11.5、11.9、12.0、12.5、15
  • NCR Teradata V2R4、V2R5、V2R6
  • Teradata 12.0、13.x、14.x、15.x

ただし、Microsoft SQL Server、Sybase、および Teradata には、既存のバグがあります。詳細については、[389] を参照してください。


[177] リバース エンジニアリングしたところ、リレーションシップが表示されません

ER/Studio Data Architect でリバース エンジニアリングを行なった場合、リレーションシップは、対象データベースで主キー制約および外部キー制約が宣言されたものに対して表示されます。

通常、主キー制約および外部キー制約が宣言されていないオブジェクトをリバース エンジニアリングした場合、これらのリレーションシップは表示されません。ただし、ER/Studio Data Architect の推定機能を使用することで、指定した推定によってリレーションシップを作成することは可能です。
この場合、インデックスまたは名前に基づいて外部キーを推定し、リレーションシップを作成するので、インデックス エディタには、リレーションシップの基になったインデックス名が主キー制約名またはユニーク制約名として表示されます。

なおMicrosoft SQL ServerおよびSybaseで主キーおよび外部キーを実装するには、制約の制限またはシステム ストアド プロシージャ(sp_primarykeyおよびsp_foreignkey)を使用します。


[178] リバース エンジニアリング時にデータベースで主キーおよび外部キーが宣言されていなくても、リレーションシップは作成できますか?

リバース エンジニアリング時にデータベースで外部キーが宣言されていなくても、リレーションシップを作成できます。

ER/Studio Data Architect では、データベースに設定されているインデックスまたはユニーク制約に基づき、主キーと外部キーを推定します。


[403] SQL Server データベースのリバースエンジニアリング

ER/Studio DA 10.0 の MS SQL Server プラットフォームにおいて、リバースエンジニアリング時に処理できない使用禁止文字があります。

< 対象バージョン: 10.0 >


データベース接続

[150] Windows XP SP2 上 のER/Studio DA からデータベースにアクセスできません

■対処■
次を確認します。

  • ミドルウェアまたは ODBC ドライバの確認
    ER/Studio Data Architect を使ってデータベースへ接続するには、Net8 に代表される 32-bit ミドルウェアをクライアント マシンにインストールする必要があります。(イティブ接続)または、適切な 32-bit ODBC ドライバをインストールし、ODBC データソースを設定する必要があります。(ODBC 接続)
  • クライアント マシンとデータベースの接続確認
    クライアント マシンからデータベースへ、アクセスできることを確認してください。確認には、ご使用のデータベース用のツール (管理ツールやクエリ ツールなど) をご利用ください。
  • Windows ファイアウォールの確認
    上記2にて、クライアント マシンからデータベースへアクセスできるにもかかわらず、ER/Studio Data Architect からデータベースへ接続できない場合は、Windows ファイアウォールの例外プログラムにER/Studio Data Architect を追加してください。

Windows ファイア ウォールの設定手順は、次のとおりです。

  1. クライアント マシンの [コントロール パネル] にて [Windows ファイアウォール] を選択し、[Windows ファイアウォール] ダイアログ ボックスを開きます。
  2. [例外] タブに移動し、[プログラムの追加] ボタンをクリックし、[プログラムの追加] ダイアログ ボックスを開きます。
  3. [プログラム] にて、ER/Studio Data Architect を選択します。
    または[参照] ボタンをクリックし、ERSTUDIO.exeのパスを指定します。(デフォルト パス: C:\Program Files\Embarcadero\ERStudiox.x、またはC:\Program Files\Embarcadero\ ERStudio Data Architect x.x)
  4. [OK] ボタンをクリックし、[Windows ファイアウォール] ダイアログ ボックスを閉じます。

■背景■
マイクロソフト サポート オンライン:「Windows XP SP3 をインストールした後、Windows ファイアウォールで一部のプログラムがブロックされる」
https://support.microsoft.com/en-us/help/842242Open a new window

< 対象バージョン: 9.x、10.0 >


[151] ER/Studio DA からデータベースに接続するには何が必要ですか?

利用する ER/Studio Data Architect (DA) アプリケーションのビット数により、必要なものが異なります。

■ER/Studio DA 32-bit アプリケーションの場合
ER/Studio DA からデータベースに接続するには、32-bit ミドル ウェアをクライアント コンピューターにインストールする必要があります。
ODBC を利用してデータベースに接続する場合は、適切な 32-bit ODBC ドライバーをインストールし、ODBC データソースを設定する必要があります

< 対象バージョン: 9.x、10.0、16.0 >

■ER/Studio DA 64-bit アプリケーションの場合
ER/Studio DA からデータベースに接続するには、64-bit ミドル ウェアをクライアント コンピューターにインストールする必要があります。
ODBC を利用してデータベースに接続する場合は、適切な 64-bit ODBC ドライバーをインストールし、ODBC データソースを設定する必要があります。

< 対象バージョン: 10.0、16.0 >

詳細につきましては、ER/Studio DA オンライン ヘルプにある各データベースの接続チェック リストを参照してください。


[152] エラー "ドライバをロードできません" が表示されます

■原因■
データベース接続しようとしているデータベースに対して、適切な接続が設定されていない可能性があります。

■対処■
次を確認してください。

  • 32-bit アプリケーションの場合
    • 対象データベースに有効な 32-bit 用 ODBC ドライバを使用すること
    • ODBC データ ソースの設定が正しいこと
  • 64-bit アプリケーションの場合
    • 対象データベースに有効な 64-bit 用 ODBC ドライバを使用すること
    • ODBC データ ソースの設定が正しいこと

※OS が 64-bit であっても 32-bit アプリケーションをご利用になる場合は、32-bit 用 ODBC ドライバが必要です。


[153] Access 上のカラムをリバース エンジニアリングできません

次を確認してください。

  • データベース ファイル (.MDBファイル) が "読み取り専用" または "ロック" モードでないことを確認する。
  • データベースのログイン ユーザーが" admin" ユーザーであることを確認する。(Access データベースへは "admin" ユーザーでログインする必要があります。)

※64-bit アプリケーションをご利用の場合、Access データベースには接続できません。


[400] データベース接続に必要なデータベース クライアントについて

■ER/Studio Data Architect 32-bit 版
32-bit 版のデータベース クライアントが必要です。
64-bit OS であっても ER/Studio DA 32-bit 版をご利用の場合は、32-bit データベース クライアントが必要です。

■ER/Studio Data Architect 64-bit 版
64-bit 版のデータベース クライアントが必要です。
※ ER/Studio Data Architect 9.x は、32-bit 版のみです。

< 対象バージョン: 9.x、10.0、16.0 >


データ ディクショナリ

[356] トリガー、プロシージャ、およびライブラリのエディタに日本語が正しく表示されません

この問題は、バージョン 9.7 で解決されています。

ER/Studio Data Architect で、データディクショナリの再利用可能なトリガー、再利用可能なプロシージャ、ライブラリのエディタ、テンプレート プロシージャ エディタ、およびトリガー テンプレート エディタに日本語を入力するためには、各エディタを開いて、フォントを日本語にしてください。

フォントを日本語にするためには、各エディタの編集エリアで、右クリックし、ショートカットメニューの [表示] をポイントし、[フォント] をクリックします。表示された [フォント] ダイアログ ボックスの [フォント名] ボックスで "MS Pゴシック" など日本語対応のフォントをクリックし、[文字セット] ボックスで [日本語] をクリックします。
エディタを開きなおすとデフォルトのフォントに戻りますので、エディタを開き直す度にフォントを設定してください。

フォントのデフォルトが日本語でないこと及び開き直すとデフォルトに戻ってしまうことは、問題として認識し、開発元に改善要求を行っております。

< 対象バージョン: 9.0、9.1、9.5、9.6 >


オートメーション インターフェース/マクロ

[149] 古いバージョンで作成したマクロを新しいバージョンでも使用できますか?

基本的に公開済みのメソッドやプロパティの動作や内容は変更されませんが、マクロで使用する Automation Interface はバージョン毎に変更が加えられています。
例えば、ER/Studio Data Architect への機能追加に伴い、メソッドやプロパティの種類が増えたり、メソッドのパラメータに指定できるデータの種類が増えたりします。

このためデータの種類が増えることによる影響が考えられますので、ご使用のバージョンで動作確認を行なうことをお勧めいたします。


[164] 自分で作成したマクロを [マクロ] タブに追加できますか?

ユーザーが作成したマクロを [モデル エクスプローラー] の [マクロ] タブに表示するには、マクロ ファイル (.bas) をマクロ ディレクトリに配置します。

マクロ ディレクトリは、[ツール | オプション] メニューをクリックして、[ディレクトリ] タブの [マクロ] で確認および変更できます。

マクロ ディレクトリに共有フォルダを指定することで、その共有フォルダを参照できるユーザー同士でマクロを共有することも可能です。

なお、[マクロ] タブに表示されるマクロ名は、マクロ ファイルの拡張子 .bas を除いたファイル名です。


[363] Windows 7 では、マクロ エディタ上の日本語が正しく表示されません

この問題は、バージョン 9.1 で解決されています。

Windows 7 にインストールされた ER/Studio Data Architect でマクロ エディタを開くと、エディタ上の日本語 (ラベル、タブ、プルダウンなど) が正しく表示されません。

■Windows 7
MacroEditor01

■Windows XP
MacroEditor02

< 対象バージョン: 9.0 >


[370] オートメーション インターフェース機能はテクニカル サポート対象ですか?

いいえ。オートメーション インターフェイス (マクロ) は、弊社テクニカル サポート対象ではありません。


[371] [オートメーション オブジェクトの参照] の日本語訳はありませんか?

ER/Studio Data Architect 16.0 の オートメーション インターフェイス ヘルプ (Automation Interface Reference) につきましては、日本語版のヘルプはございません。


[372] [Sax Basic ヘルプ] が開けません

お使いのクライアント環境によっては、ヘルプ ファイルを開くためのモジュールが不足していることがあります。次の Microsoft 社 Web サイトより、対応するモジュールをダウンロードしてみてください。

マイクロソフト サポート オンライン:「Windows ベースのプログラムでヘルプを開くときのエラー:「機能は含まれていません」または「ヘルプはサポートされていません」」
https://support.microsoft.com/en-us/help/917607/error-opening-help-in-windows-based-programs-feature-not-included-or-hOpen a new window


[373] コンピューターを変更したところ、マクロの出力結果が異なります

過去、Excel のバージョンを特定のバージョン以上に上げたところ、ER/Studio DA のバージョンが特定のバージョンより古い場合に、出力結果が異なる事例がございました。

OS、Excel または ER/Studio (Data Architect) のいずれかのバージョンを変更された場合は、ご使用のバージョンで動作確認を行うことをお勧めいたします。


インポート/エクスポート

[127] モデルのダイアグラム イメージをエクスポートできますか?

ER/Studio Data Architect では、データ モデルをイメージにエクスポートできます。
[ファイル] メニューの [イメージのエクスポート] をクリックし、表示されたダイアログ ボックスで、エクスポートするイメージのタイプ、コンテンツ、サイズなどを指定して作成します。

ファイル タイプは、拡張メタファイル (.emf)、GIFイメージ (.gif)、JPEGイメージ (.jpg)、PNGイメージ (.png)、Windowsビットマップ (.bmp)から選択することができます。


[144] XML のスキーマ定義(XSD)を出力できますか?

[ファイルのエクスポート]または[XML スキーマ生成]機能にて、XML スキーマをモデルから生成することが可能です。

[XML スキーマ生成]機能では、ウィザードを使用して、論理モデルおよび物理モデルに基づいたスキーマを作成することができます。ウィザードでは、必要なオプションを選択して、オブジェクトを XML スキーマを表すツリー構造へドラッグ&ドロップするだけで、独自にカスタマイズした XML スキーマ構造を生成できます。

また、[ファイルのエクスポート]では、文書型定義(DTD)をエクスポートすることも可能です。


[146] ER/Studio DA のモデルの情報を Excel に出力できますか?

ER/Studio Data Architect のモデル情報を Excel 形式に出力するには、次のいずれかの方法を実施します。

■オートメーション インターフェイスを使う場合
[モデル エクスプローラ] の [マクロ] タブにて、[すべてのエンティティをEXCELにエクスポート] を実行します。

■ER/Worksheet を使う場合
弊社 提供のER/Worksheet (Excel アドイン) を使用します。 ER/Worksheet は、弊社と ER/Studio DA のメンテナンス契約を締結中のお客様へ提供しているフリーウェアです。

  1. ER/Worksheetにて、[レポート生成] を選択します。
  2. [ER/Worksheet レポート ウィザード1] にて、[レポートの種類] の [エンティティ / 属性](または [テーブル / カラム]) レポートを選択し、[次へ] ボタンをクリックします。
  3. [ER/Worksheet レポート ウィザード2] にて、出力したい定義のチェック ボックスをオンにします。
  4. [実行] ボタンをクリックし、レポートを生成します。
http://www.fujitsu.com/jp/group/fetec/solution/erworksheet/index.htmlOpen a new window

[389] SQLファイルからのモデルのインポートについて

ER/Studio Data Architect 9.6、9.7、10.0、16.0 では、次のデータベースに対応する SQL ファイルをインポートした場合、エラーが表示されることがあります。

  • Microsoft SQL Server
  • Sybase ASE
  • Syabse ASA
  • Teradata

本件は、問題として、開発元へ修正を要求しています。

< 対象バージョン: 9.6、9.7、10.0、16.0 >


[405] MetaWizard インポートブリッジしようとするとエラーが発生します

ER/Studio Data Architect (DA) 10.0 から、MetaWizard インポート ブリッジの一部の機能が利用できるようになりました。

しかしながら、ER/Studio DA 日本語版では、ERwin の情報を正しくインポートできません。

本件は、問題として認識し、開発元へ改善要求しております。

< 対象バージョン: 10.0、16.0 >


インストール/起動/ライセンス

[362] エラー "この Serial Number の登録回数の上限に達しました" が表示され、ライセンス認証できません

■原因■
エラー メッセージ "この Serial Number の登録回数の上限に達しました" または "The registration limit for this serial number has been reached" は、利用中のライセンスがライセンス適用回数の上限に達すると表示されます。

■対処■
次の連絡先に [製品登録 (使用許諾) の上限更新] をご依頼ください。

エンバカデロ・テクノロジーズ合同会社
インフォメーションサービスセンター
TEL: 03-4540-4148
E-mail: Japan.Info@embarcadero.com
Web フォーム: http://supportforms.embarcadero.com/Open a new window
受付時間: 月曜~金曜 10:00~12:00/13:00~17:00 (土日祝日およびエンバカデロ社休業日を除く)

< 対象バージョン: 9.x、10.0、16.0 >


[365] ER/Studio 製品は、仮想環境で利用できますか?

コンカレント ライセンスの場合は、仮想環境でご利用いただけます。
しかしながら、仮想環境上でのみ発生する事象につきましては、すべてテクニカル サポート対象外となりますので、ご注意ください。

ワークステーション ライセンスの場合は、ライセンス規約により、仮想環境では、ご利用いただけません。

詳細については、次のドキュメントを参照してください。

ERStudio_仮想環境でのライセンス使用について (199 KB)

< 対象バージョン: 9.x、10.0、16.0 >


[366] UAC が有効なコンピュータで、インストールに失敗します

ER/Studio Data Architect (DA) のインストールには、ローカルの管理者権限が必要です。

Windows 7 や 8のように、ユーザー アカウント制御 (UAC; User Account Control) が有効なコンピューターの場合は、次の手順でインストールします。

  1. ローカルの管理者ユーザーでログインして、ER/Studio DA をインストールします。
    実行ファイル (.exe) を右クリックして、ショートカット メニューの [管理者として実行] をクリックして、インストールします。
  2. コンピューターを再起動します。
  3. ER/Studio DA を右クリックして、ショートカット メニューの [管理者として実行] をクリックして、起動します。
    2 回目以降は、任意のユーザーで起動できます。

ネットワーク経由またはメディアからインストールすると、インストールに失敗することがあります。必ず、実行ファイル (.exe) をローカル ディスク (例: C ドライブ) にコピーしてから、ローカル ディスク上でインストールします

< 対象バージョン: 9.x、10.0、16.0 >


[368] ER/Studio DA バージョンアップ時の注意点を教えてください

ER/Studio Data Architect (DA) をご利用いただく前に、次のドキュメントを参照してください。このドキュメントには、ER/Studio DA をご利用いただく上での注意点が記載されています。

FETEC Products Download Center:「ERStudio16.0_お使いになる前に」
http://www.fetec.fujitsu.com/file/download/ERStudio160_BeforeUse_r2.pdfOpen a new window

ER/Studio Repository をご利用いただいている場合は、ER/Studio Repository のバージョンアップも必要な可能性があります。対応する ER/Studio Repository のバージョンをご確認ください。

この他に、製品の Readme およびオンライン ヘルプも併せて参照してください。

< 対象バージョン: 9.x、10.0、16.0 >


[367] ライセンス認証しても [製品登録] ダイアログが表示されます

■原因■
ER/Studio Data Architect (DA) の初期設定が正常に実施できなかったために、ライセンス認証に失敗している可能性があります。

■対処■
ER/Studio DA をアンインストールおよびインストールしてから、再度ライセンス認証を試します。
ER/Worksheet をご利用の場合は、Excel > ER/Studio DA > ER/Worksheet の順序でインストールする必要があります。

対処手順は、次のとおりです。ここでは、Windows 7 を例にしています。 この手順は、ローカルの管理者権限を持つユーザーで実施する必要があります。

  1. ER/Studio DA をアンインストールします。
    [スタート] ボタンをクリックして、[コントロール パネル | プログラムのアンインストール] をクリックして、ER/Studio DA を選択して、[アンインストール] をクリックします。
  2. コンピューターを再起動します。
  3. ER/Studio DA をインストールします。
    インストーラー (.exe ファイル) をローカルにコピーして、ローカル上のインストーラーを右クリックして、[管理者として実行] をクリックします。
  4. コンピューターを再起動します。
  5. ER/Studio DA を起動します。
    [スタート] メニューまたはデスクトップ上の ER/Studio DA を右クリックして、[管理者として実行] をクリックします。
    [管理者として実行] からの起動は、初回のみ必要です。2 回目以降の起動は、任意のユーザーで実施できます。
  6. [製品登録] ウィンドウで、ライセンス認証します。
    ライセンス認証の詳細につきましては、次のドキュメントをご参照ください。

    FETEC Products Download Center:
    「ER/Studio Data Architect 16.0 ライセンスについて 」
    http://www.fetec.fujitsu.com/file/download/ERStudio_DA_160_Licensing_r4.pdfOpen a new window

上の手順を実施しても、[製品登録] ウィンドウが表示される場合は、次の連絡先にお問い合わせください。

エンバカデロ・テクノロジーズ合同会社
インフォメーションサービスセンター
TEL: 03-4540-4148
E-mail: Japan.Info@embarcadero.com
Web フォーム: http://supportforms.embarcadero.com/Open a new window
受付時間: 月曜~金曜 10:00~12:00/13:00~17:00 (土日祝日およびエンバカデロ社休業日を除く)

< 対象バージョン: 9.x、10.0、16.0 >


[374] ライセンスは、どのバージョンでも共通して利用できますか?

ER/Studio Data Architect (DA) のライセンス (シリアル ナンバーまたはライセンス証明書番号) は、バージョンごとに発行されています。

このため、ER/Studio DA をバージョンアップする場合は、ご利用いただくバージョンに対応したライセンスを適用する必要があります。

< 対象バージョン: 9.x、10.0、16.0 >


[376] インターネットに接続せずに、ライセンス認証できますか?

ER/Studio Data Architect (DA) のライセンスは、オンラインまたはオフラインで認証します。インターネットに接続できない環境でのライセンス認証には、オフライン認証をご利用ください。

ライセンス認証の詳細については、次のドキュメントを参照してください。

FETEC Products Download Center:
「ER/Studio Data Architect 16.0 ライセンスについて」
http://www.fetec.fujitsu.com/file/download/ERStudio_DA_160_Licensing_r4.pdf (1.19 MB )

< 対象バージョン: 9.x、10.0、16.0 >


[378] [製品登録] ダイアログでライセンス認証できません

ライセンス認証の手順については、次のドキュメントを参照してください。

FETEC Products Download Center:
「ER/Studio Data Architect 16.0 ライセンスについて」
http://www.fetec.fujitsu.com/file/download/ERStudio_DA_160_Licensing_r4.pdf (1.19 MB )

その他のライセンス認証および Embarcadero Developer Network に関するご質問や問題につきましては、次の連絡先にお問い合わせください。

エンバカデロ・テクノロジーズ合同会社
インフォメーションサービスセンター
TEL: 03-4540-4148
E-mail: Japan.Info@embarcadero.com
Web フォーム: http://supportforms.embarcadero.com/Open a new window
受付時間: 月曜~金曜 10:00~12:00/13:00~17:00 (土日祝日およびエンバカデロ社休業日を除く)

< 対象バージョン: 9.x、10.0、16.0 >


[385] ライセンス認証について教えてください

ER/Studio Data Architect (DA) をご利用いただくには、インストール後、オンラインまたはオフラインでのライセンス認証が必要です。

ライセンス認証の詳細については、次のドキュメントを参照してください。

FETEC Products Download Center:
「ER/Studio Data Architect 16.0 ライセンスについて」
http://www.fetec.fujitsu.com/file/download/ERStudio_DA_160_Licensing_r4.pdf (1.19 MB )

< 対象バージョン: 9.x、10.0、16.0 >


[386] 製品メディアをドライブに挿入してもインストールが開始されません

新規にご購入いただいた場合にお送りしている製品メディアは、自動実行 (Autorun) しません。

製品メディアの該当フォルダにある実行ファイル (.exe) をローカル ディスク (例: C ドライブ) にコピーしてから、ローカル ディスク上で手動でインストールを開始します。


[396] ER/Studio DA 9.7 のインストールで、環境変数が正しく追加されません

この問題は、バージョン 10.0 で解決されています。

■発生条件■
この問題は、次のすべての条件に該当するコンピューターに ER/Studio Data Architect (DA) 9.7 をインストールした場合に発生します。

  • ER/Studio DA 9.1、9.5 または 9.6 のいずれもインストールされたことがない
  • システム環境変数 Path が 1,024 文字を超えている

■症状■
ER/Studio DA 9.7 をインストールすると、システム環境変数 Path が次のいずれかに書き換えられます。

  • ;C:\Program Files\Common Files\Tom Sawyer Software\8.0.0
  • ;C:\Program Files (x86)\Common Files\Tom Sawyer Software\8.0.0

< 対象バージョン: 9.7 >


[397] ER/Studio DA 日本語版の専用インストーラーが見つかりません

ER/Studio Data Architect (DA) 10.0 では、インストーラーが英語版と日本語版で統合されています。

ER/Studio DA 10.0 のインストーラーでは、コンピューターのシステム ロケールが日本語の場合は日本語版が、英語の場合は英語版が自動的に選択されて、アプリケーションがインストールされます。

< 対象バージョン: 10.0 >


[398] 64 ビット アプリケーションはありますか?

バージョン 10.0 から ER/Studio Data Architect および ER/Studio Repository で、64 ビット アプリケーションの提供が開始されました。

バージョン 16.0 からは、ER/Studio Repository は、ER/Studio Team Server に統合されました。

< 対象バージョン: 10.0、16.0 >


[399] 64-bit 版の利用にあたって、注意点を教えてください

ER/Studio Data Architect (DA) 64-bit 版を利用する場合、次の点に注意してください。

32-bit 版と共存できません
ER/Studio DA 64-bit 版と 32-bit 版を同じコンピューターにインストールすることはできません。いずれか一方のみをインストールします。

ライセンスは、32-bit 版と 64-bit 版で共通です
ER/Studio DA 64-bit 版と 32-bit 版では、同じライセンスを利用できます。 ただし、利用中にビット数の違う ER/Studio DA に変更した場合、ライセンスの再適用が必要になることがあります。

ER/Studio Repository を利用する場合、ビット数に注意します
ER/Studio DA のバージョンが 9.x および 10.0 で、ER/Studio Repository を利用する場合、ER/Studio DA が 64-bit 版であれば、ER/Studio Repository も 64-bit 版を利用する必要があります。
ER/Studio DA のバージョンが 16.0 から ER/Studio Repository は、ER/Studio Team Server に統合されました。
ER/Studio Team Server (64-bit 版のみ) の場合は、ER/Studio DA が 32-bit 版であっても、ER/Studio Team Server を利用できます。

< 対象バージョン: 10.0、16.0 >


[408] ER/Studio Data Architect 10.0 をインストールして起動しようとすると、エラー ”コンピューターにtsvx9editor80udep32.dll がないため、プログラムを開始できません。" が表示されて、起動できません

■原因■
この問題は、古いバージョンの ER/Studio Data Architect をアンインストールして、ER/Studio Data Architect 10.0 をインストールしたコンピューターに発生します。

ER/Studio Data Architect は、バージョン 10.0 からインストールの仕組みが変更されました。ER/Studio Data Architect 10.0 には、インストール時の内部的な条件により、ER/Studio Data Architect のグラフィック エンジンである Tom Sawyer Software がインストールされないという不具合があるため、この問題が発生しています。

■対処■
Tom Sawyer Software を手動でインストールする必要があります。

詳細な対処法については、弊社テクニカル サポートまでお問い合わせください。
https://www.fujitsu.com/jp/group/fetec/inquiry/user/techsupport.html

< 対象バージョン: 10.0 >


ER/Worksheet

[358] ドメインがバインドされた属性/カラムのプロパティを更新できません

モデル更新する前に、ER/Studio Data Architect 上で、対象のドメインがバインドされた属性/カラムの [バインドされたデータを上書き] オプションを有効化してください。


[410] レポート生成/エクスポートで、データの桁数に "-2" が出力されます

ER/Worksheet のレポート生成およびエクスポート機能では、ER/Studio Data Architect (DA) に設定された値がそのまま出力されます。

桁数を指定できないデータ型の場合、ER/Studio DA は、桁数に "-2" という内部的な値を持っています。

このため、ER/Worksheet でレポート生成またはエクスポートすると、桁数を指定できないデータ型の [桁数] 列に "-2" が出力されます。

出力された "-2" という値を消すには、お手数ではございますが、レポート生成またはエクスポートした後で、Microsoft Excel 上の該当の値を削除してください。


[369] ER/Worksheet を起動しようとすると、パスワードを求められます

Windows Vista 以降のユーザー アカウント制御 (UAC; User Account Control) が有効なコンピューターの場合、ER/Studio Data Architect (DA) のインストールが完了していない可能性があります。

ER/Studio DA のインストールを完了させてください。

手順につきましては、[366] を参照してください。


[409] ER/Studio DA を再インストールしたら、ER/Worksheet が起動しなくなりました

ER/Worksheet は、ER/Studio Data Architect (DA) の後にインストールされる必要があります。

ER/Studio DA を再インストールする場合、ER/Worksheet も再インストールしてください。


[412] ER/Worksheet を起動しようとすると、メッセージが表示されます

ER/Worksheet を起動しようとすると、次のようなメッセージが表示されることがあります。

  • ER/Studio がインストールされていません。インストールを中止します。
  • プロジェクトまたはライブラリが見つかりません。
  • 非表示モジュール Module1 内でコンパイル エラーが発生しました。
  • 実行時エラー '13': 型が一致しません。

■原因■
Windows Vista 以降のユーザー アカウント制御 (UAC; User Account Control) が有効なコンピューターの場合、ER/Studio Data Architect (DA) のインストールが完了していない可能性があります。

■対処■
ER/Studio DA のインストールを完了させてください。

手順につきましては、[366] を参照してください。


ELC

[379] ELC とは何ですか?

ELC とは、Enterprise License Center のことで、ER/Studio 製品のライセンス管理アプリケーションです。

コンカレント ライセンスをご利用の場合に必要です。ワークステーション ライセンスでは、必要ありません。

詳細については、次の URL からダウンロードできるドキュメントを参照してください。

FETEC Products Download Center:
「Enterprise License Center(ELC) 5.3 インストール&セットアップガイド」
http://www.fetec.fujitsu.com/file/download/ELC_5.3_Install&Setup_FETEC_r4.pdf (1.90 MB ) 


なお、Linax、Solaris 版の ELC につきましては、弊社テクニカル サポート対象外です。

< 対象バージョン: 10.0 >


[380] ELC では、どのバージョンの ER/Studio DA を管理できますか?

Enterprise License Center (ELC) では、ER/Studio Data Architect 9.x、10.0、16.0 のコンカレント ライセンスが管理できます。

< 対象バージョン: ELC 5.3 >


[381] ELC のインストーラーは、どこで入手できますか?

Enterprise License Center (ELC) のインストーラーは、次の開発元の URL からダウンロードできます。

詳細については、次の URL からダウンロードできるドキュメントを参照してください。

FETEC Products Download Center:
「Enterprise License Center(ELC) 5.3 インストール&セットアップガイド」
http://www.fetec.fujitsu.com/file/download/ELC_5.3_Install&Setup_FETEC_r4.pdf (1.90 MB )

< 対象バージョン: ELC 5.3 >


[383] コンカレント ライセンスの利用方法が分かりません

コンカレント ライセンスを利用するには、Enterprise License Center を構築する必要があります。

詳細については、次の URL よりダウンロードできるドキュメントを参照してください。

FETEC Products Download Center:
「Enterprise License Center(ELC) 5.3 インストール&セットアップガイド」
http://www.fetec.fujitsu.com/file/download/ELC_5.3_Install&Setup_FETEC_r4.pdf (1.90 MB )

< 対象バージョン: ELC 5.3 >


[384] ELC のサービス名がマニュアルと違います

Enterprise License Center (ELC) 5.3 の Windows サービス名は、"ELC" です。

開発元公開のマニュアル「Embarcadero License Center クイックマニュアル」に記載されているサービス名 "Elise" は、ELC 4.1 以前のバージョンのサービス名です。

"ELC" と "Elise" は、同様のサービスです。

< 対象バージョン: ELC 5.3 >


[394] ELC に関するメッセージが英語です

Enterprise License Center (ELC) は、翻訳されていません。

このため、ELC と ER/Studio Data Architect の接続で表示されるエラーや警告メッセージは、英語で表示されます。

< 対象バージョン: ELC 5.3 >
< 対象バージョン: 9.x、10.0、16.0 >