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Instructions On How To Use the Fujitsu 32-key Keypad Mapping Utility

1 Package Name

Fujitsu 32-Key Keypad Mapping Utility

2 Contents of the Package
2.1 Windows based executable, 32-key Keypad Mapping Utility

Map32KeyPad.exe

Whhuut Fujitzu 32-keyp Keypad Mapping Utility

|32 Fuijitzu 32-key Kevpad Mapping Lty

Yerzion 1.0.741

Ltility Function: For mapping and programming Fujitzu
FOS 32-key Keppad

Copyright 2001 Fujitzu Tranzaction Salutions Ine.

2.2 A dynamic linked shared library file

LowLevelCall.dll

2.3 An Initialization File

Map32KeyPad.ini

2.4 A Default (qwerty type keyboard) Keycode and Process File

gwerty.eng
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Instructions On How To Use the Fujitsu 32-key Keypad Mapping Utility

2.5 Five default keytable layout files

2.5.1 Keypad32A.dat

The layout of this file is as follows:

K& Fuiitsu 32-Key Keypad Mapping Utility
File Kewpad Help

—Key Code

B -
g B
]

A

A

M7 _
F- Shift

L- Ctrl

L- Al

Space

Mum Lock,

Ezc

I |

— Aittribute

[+ Ordinary Keycode

[T Bepeat*] Keycode Walue
[T Bepeat*2 Keycode Walue
[ Shift Code Added

[T Chl Code Added

[T Alt Code Added

[T Beturns Break Caode Only
[T Prefiz Code Added

—Size

[T 241 Hrozontal
[T 1x2Verdtical
[T 2:2 Square

[KEYPAD 324 DAT

Figure 1 - Keypad32A.DAT
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Instructions On How To Use the Fujitsu 32-key Keypad Mapping Utility

2.5.2 Keypad32B.dat

The layout of this file is as follows:

Eﬂl Fujitszu 32-Keyp Keypad Mapping Utility

File Keppad Help

— kKeypad —Key Code

A4
A
7 _
R- Shift

L- Ctrl

L- Al

Space

Murm Lock,

Eac

F M

— &ttribute

v Ordinary Kepcode

[T Repeat*1 Keycode Walue
[T Repeat*? Keycode Walue
[~ Shift Code Added

[~ Chl Code Added

[~ Al Code Added

[~ Returnz Break Code Only
[~ Prefix Code Added

—Size

- = | En [~ 2x1 Hrozontal
nLer [ 1=2Wertical

[~ 2x2 Square

[KEYFPAD32B.DAT

Figure 2 - Keypad32B.DAT

12/13/01



Instructions On How To Use the Fujitsu 32-key Keypad Mapping Utility

2.5.3 Keypad32C.dat

The layout of this file is as follows:

Eﬂl Fujitszu 32-Keyp Keypad Mapping Utility

File Keppad Help

— kKeypad —Key Code
Null Null Null Null E
Func Func Func Func 12
3
MNull MNull MNull MNull g
Func Func Func Func E
7
]
MNull MNull MNull MNull 9
Func Func Func Func 1]
s ;I
MNull MNull MNull MNull
Func Func Func Func — &ttribute
v Ordinary Kepcode
Mull [T Repeat*1 Keycode Walue
Func [T Repeat*? Keycode Walue

[~ Shift Code Added
[~ Chl Code Added

full I At Code Added
[~ Returnz Break Code Only
[~ Prefix Code Added
Mull
Func i
W 11 Single Key
Mull [~ 2%1 Hrozontal
Func [ 1=2Wertical
[~ 2x2 Square

KEYPADIZC.DAT

Figure 3 - Keypad32C.DAT
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Instructions On How To Use the Fujitsu 32-key Keypad Mapping Utility

2.5.4 Keypad32D.dat

The layout of this file is as follows:

K& Fuiitsu 32-Key Keypad Mapping Utility

File EKewpad Help
— Keppad —Key Code
Null ;*’ ”
F
unc 5
K]
Mull g
Func
B
7
a
Mull 3
Func 1]
4 =]
Mull
Func — Attribute
[+ Ordinary Keycode
Null Null Null Null ™ Repeat™ Kepcode Value
Func Func Func Func [T Repeat*2 Kepcode Value
[ Shift Code Added
[T Chl Code Added
|||
[T Beturns Break Caode Only
[T Prefiz Code Added
Mull Mull Mull Mull
Func Func Func Func .
— Size
¥ {11 Single Key
Null Null Null Null ™ 2«1 Hrozontal
Func Func Func Func [ 1=2Vertical
[T 2:2 Square
[KE'YPAD32D.DAT

Figure 4 - Keypad32D.DAT
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Instructions On How To Use the Fujitsu 32-key Keypad Mapping Utility

2.5.5 Keypad32G.dat

The layout of this file is as follows:

K& Fuiitsu 32-Key Keypad Mapping Utility
File Eewpad Help

— Keppad —Key Code
Hull Func -
.
1
2
K]
4
]
7
a
3
1]
4 =]
— Aittribute

[+ Ordinary Keycode

[T Bepeat*] Keycode Walue
[T Bepeat*2 Keycode Walue
[ Shift Code Added

[T Chl Code Added

[T Alt Code Added

[T Beturns Break Caode Only
[T Prefiz Code Added

—Size

[T 241 Hrozontal
[T 1x2Verdtical
[T 2:2 Square

[KEYPAD325.DAT

Figure 5 - Keypad32G.DAT

2.6 One Read-Me Instruction File

This file

8 12/13/01



Instructions On How To Use the Fujitsu 32-key Keypad Mapping Utility

3 What can this Utility do?

It can Open an existing Keytable file, e.g., Keypad32A.dat.
It can Assign and define new key caption, key attribute, and key size to all keys.

It can Save or Save As an updated Keytable file.

It can Create a keytable file. This prints out the sequence of key values (key code and
attribute) in the currently loaded Keypad layout.

It can Print a Key Map Image. Print the image picture of the current Keypad.

It can Print Keypad Value. Print a table of Keypad value in the order, bottom to top, (Al to
H4), values printed include: location ID, Scanning Address, Key Code, Attribute, Size, Key Top
(Caption).

It can Display five default Keypad layouts.

It can Elash currently loaded Keypad layout into the keyboard memory.

4 How to update a Keypad .DAT file

a) Open a Keypad .DAT file, e.g., Keypad32A.dat
click File -> Open -> and select a Keypad file from the file list, or
click File -> New to start from an un-assigned Keypad, or
click Keypad -> Get Default Key Map and select one of the default layouts

]

File BGY:CE Help
sreny Get Default Key Map r| Key Map-A

Flash Keymap to Memory Key Map-B
Mull Hull Hull Hull Key Mﬂp—c =
Func Func Func Func .
Key Map-D
Key Map-G
Mull Mull Mull Mull 7
Func Func Func Func ]
B
7
Mull Null Null Null g
F F F F
unc unc unc unc 1 lI
Mull Mull Mull Mull
Func Func Func Func |—.-i'-.ttril:|ute |
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Instructions On How To Use the Fujitsu 32-key Keypad Mapping Utility

b) Assign a Key Code Value
click any key on the Keypad
select a Key Code from the text box, use the scroll bar to view the key code list

C) Assign Key Attribute(s)

select Attribute by clicking check box(es), there are eight check boxes available:

Attribute Value

Meaning

Ordinary Keycode

Generates keystroke values recognized by Windows, Linux,
DOS, etc., operating systems.

Repeat*1 Keycode Value

Key value is repeated. e.g., if '0' is selected, then '00" is input
when the key is depressed.

Repeat*2 Keycode Value

Key value is repeated twice. e.g., if '0' is selected, then '000' is
input when the key is depressed.

NOTE: If both "Repeat*1 Keycode Value" and "Repeat*2
Keycode Value" are checked, then if '0' is selected, then '0000'
is input when the key is depressed.

Shift Code Added The "shift" attribute is input along with the key value.
Ctrl Code Added The "Citrl" attribute is input along with the key value.
Alt Code Added The "Alt" attribute is input along with the key value.

Returns Break Code Only

No "Make" code is generated. Values will not be recognized by
Windows, Linux, DOS, etc., operating systems. Used in
conjunction with the "Prefix Code Added" attribute to generate
POS keys processed by FJ OPOS/JavaPOS Services.

Prefix Code Added

See "Returns Break Code Only" above.

Within these options, Ordinary Keycode is mutually exclusive with all others and it will be
automatically checked if all others are unchecked.

d) Select desired Key Size, by clicking a check box for 1x1 Single Key, 2x1 Horizontal Key,
1x2 Vertical Key, or 2x2 Square Key.

To enlarge a key, all included single keys' key codes must be set to "Null Func". The
selected key should be in the bottom right-hand corner position of the desired multi-key.
See the following set of diagrams that explain the multi-key mapping process.

[ Ordinamy Kepcode

Mull Mull Mull Mull [ Repeat”] Kepcode Value
Func Func Func Func [ Repeat™2 Kevcode Walue
[~ Shift Code Added
[ Chl Code Added
|| | |G
[~ Returnz Break Code Only
.................... [~ Prefis Code Added
Mull Mull Mull Mull
Func Func | |i Func | Func .
Size
[v 121 Single Key
Mull Mull Mull Mull [ 2¢1 Hrozontal
Func Func Func Func [ 1u2Vertical
[T 2u2 Sauare
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Instructions On How To Use the Fujitsu 32-key Keypad Mapping Utility

Now map a 2x1 Horizontal key. The layout now looks like this.

Mull Mull Mull Mull
Func Func Func Func
Mull Mull Mull Mull
Func Func Func Func
Mull Mull
Func Null Func Func
Mull Mull Mull Mull
Func Func Func Func

[v Ordinam Keycode

[~ Repeat®l Kevcode Walle
[ Repeat*? Kevcode YWalle
[~ Shift Code &dded

[ Ctl Code Added

[~ Al Code &dded

[ FReturnz Break Code Only
[ Prefix Code Added

Size
[~ 141 Single ey
[v 2u1 Hrozontal
[ 1x2ertical
[ 242 Square

Now map a 1x2 Vertical key. The layout now looks like this.

Mull Mull Mull Mull
Func Func Func Func
Mull Mull Mull
Func Func Func
Mull
Func
Hull Hull Hull
Func Func Func
Hull Hull Hull Hull
Func Func Func Func

v UTainany Leycode
[ Repeat*l Kepcode Value
[ Repeal*? Keycode Value
[~ Shift Code Added

[T Chl Code Added

[ Alt Code Added

[~ Returns Break Cade Only
[~ Prefix Code Added

Size
[T 1x1 Single Key
[T 241 Hrozontal
W 1:2ertical
[ 2«2 Sguare

Finally, an example of a 2x2 mapping. The layout now looks like this.

Mull Mull Mull Mull
Func Func Func Func
Mull Mull
Func Func
Mull Func
Hull Hull
Func Func
Hull Hull Hull Hull
Func Func Func Func

v UraInary reycode
[ Repeat®l Kevcode Walue
[ Repeat*? Kevcode Walue
[~ Shift Code Added

[ Ctrl Code Added

[~ Al Code Added

[~ Returns Break Code Only
[~ Prefix Code Added

Size
[T 1x1 Single Key
[~ 2wl Hrozontal
[ w2 Vertical
[ 2u2 Square

Click File -> Save or Save As to save the current working Keypad to a file. The file
name extension is .DAT.

11
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Instructions On How To Use the Fujitsu 32-key Keypad Mapping Utility

5 How to Create a KeyTable file

a) Click File -> Create Key Table File -> type in a file name. The default extension is
.TBL.

b) A Keytable file stores the Key Code and Attributes of each key in the order of Keypad
memory 0x8000 to 0x809f.

6 How to Print Key Map Image

a) Click File -> Print Key Map Image -> OK
b) Print Key Map Image prints the current working Keypad image.

7 How to Print Keypad Value

a) Click File -> Print Keypad Value -> Yes on "Are You Ready To Print The Current
Keypad Values" dialogue prompt.

b) The output is printed in the order of the bottom left-hand corner key (A01) to the bottom
right-hand corner key (A13), and bottom to top row by row from (A01) to (A13) to (HO1)
to (H13) in Cartesian position.

C) The output includes Cartesian position, scan address, key code, attribute(s), key size,
and key top (caption) of all keys.

8 How to display default layout of a Keypad

a) Click Keypad -> Get Default Key Map -> select one of the five default Keypad layouts
(A, B, C, D, G).
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Instructions On How To Use the Fujitsu 32-key Keypad Mapping Utility

9 How to flash a keymap to Keypad Memory

a) Click Keypad -> Flash Keymap to Memory, a message box prompts "It Will Take
About Five Seconds to Flash the Table to the Memory. Are You Ready?", click OK to
continue the process, click No to abort the option.

ﬁ Fujitzu 32-Key Keppad Mapping Utility
File EKewpad Help

— Keppad —Key Code

B “
g B
]

A

A

Space
Mum Lock,
Ezc

47 [
R- Shift
L- Cil
L- &)t
|7

[t %Al T ake About Five Seconds ta Flazh the T able to the Memaony?
Are v'ou Ready?

alue
Tes Ha alue

[T Chl Code Added

5L 5 - I~ Alt Code Added

[T Beturns Break Caode Only
[T Prefiz Code Added

1 2 3 —Size
[+ 1x1 Single Key
0 00 Enter [T 241 Hrozontal
- [T 1x2Verdtical
[T 2:2 Square
[KEYPAD 324 DAT

b) While the utility is flashing the layout to the Keypad memory, the mouse and keyboard
will be halted.

Please refrain from doing any other functions on the computer during this
process !

C) Once the process is completed, click OK to the prompted message box.
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Instructions On How To Use the Fujitsu 32-key Keypad Mapping Utility

10 Advanced Features

The mapping utility provides two features which allow users to select background color and
use a graphic icon for a key. There are four icons used in the default Keypad, Up-Arrow,
Down-Arrow, Left-Arrow, and Right-Arrow. The caption of these keys are graphical, all others
keys are represented in text mode.

The gwerty.eng defines all key values. Each fixed-length record represents a key which
contains the following, using the Left Arrow key as an example:

Field Name Length Example Data
1. Scanning Address (2-byte), 08
2. KeyCode (2-byte), 5D
3. Work Field (5-byte), 00000
4, Cartesian Location (3-byte), A02
5. Key Caption (15-byte),  Left Arrow
6. Icon File Name (12-byte), arwilt.ico
7. Red Color Weight (3-byte), 000
8. Green Color Weight (3-byte), 255
9. Blue Color Weight (3-byte), 255
10.  Delimiter character (1-byte), |
11. Carriage Return/Line Feed (2-byte) 0x0d, Ox0a

The Left Arrow Key record contains: 085D00000A02Left Arrow  arwlt.ico 000255255

The three colors weigh from 0 to 255 using the RGB rules. There are only 4 fields that can be
modified: 6) Icon File Name, 7) Red weight, 8) Green weight, and 9) Blue weight.

Qwerty.eng is a fixed-length record text file that can be edited using a text editor, e.g.,
Windows Notepad.
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